Provider email system down.
Incident Report for Yukiko
Resolved
This incident has been resolved.
Posted Sep 20, 2022 - 17:08 BST
Identified
Our email provider email systems are currently down, we are unable to read or send any emails at the moment.
for more information: https://asthriona.statuspage.io/incidents/vcnpt3bpl0k9
Posted Sep 20, 2022 - 16:22 BST
This incident affected: Network (Email).