Email cluster Down.
Incident Report for Yukiko
Resolved
This incident has been resolved.
Posted Jul 28, 2023 - 05:08 BST
Investigating
We have noticed that our email servers are down. We are currently investigating the issue.
Posted Jul 27, 2023 - 10:54 BST
This incident affected: Network (Email).